Support

Installing Slitaz on thin client T5545 (7 posts)

Topic tags: T5545, VGA=771
  • Profile picture of Zainka Zainka said 2 months, 3 weeks ago:

    I have benn trying for a while to reuse som old thin clients laying around and found that the Slitaz distro should be perfect for that matter regarding its minimalistic hw requirement. Downloaded what is todays latest rolling variant and tested this.

    The base version boots fine and I get to terminal and everything is working except I cant get the network up and running. Working on that for the moment. However, I am not able to load live or gtkonly, i.e. the variants using a windowsmanager.

    The graphic board seems to be unsupported since the boot process halts just before I think it should switch to the windowmanager. I tried by altering boot options with VGA=771 but with no success.
    I tried this because befor I switched to the Slitaz distro I have been trying to use LUBUNTU on the t5545, and here I was able to boot to desktop when boot option VGA?771 was set. But since LUBUNTU requires more from the HW I was not able to install this litle beauty.

    The t5545 in my hand is running on 512MB flash disk and 1GB RAM.

    I am not very familiar with available boot options to use to make Slitaz running ti desktop, so there might be an option to make it work, but if someone know where I should look, I can do the looking. Tips are always welcome

    So the question is, does anyone have references or experiences with the T5545 hp thin client running Slitaz`???

  • Profile picture of Zainka Zainka said 2 months, 3 weeks ago:

    Additional info. ifconfig shows only lo, not eth0 or anything else

  • Profile picture of kultex kultex said 2 months, 3 weeks ago:

    the t5545 has a via eden, which is does not work in 4.0 – because of problems with glibc 4.0 is only i686 compatible and this via eden is i585.

    You have to use rolling to get X

  • Profile picture of Zainka Zainka said 2 months, 3 weeks ago:

    I AM using rolling. I also said so in my prev. post but I agree that my initial post was kinda messy.

    But I am using rolling and I have tried all boot variants in the live cd, both the Live, Core Live, gtkonly live and justx live. Only the base is able to boot fully, but to terminal.

    So question remains, do I have to set a VGA option while booting to have desktop?

  • Profile picture of Zainka Zainka said 2 months, 3 weeks ago:

    I was able to install slitaz on thinclient T5545 w/grub as bootøloader (0.97). I choose to download and install the <b>slitaz-rolling-core.iso</b> since only the rolling liveCD option <b>Core</b> with boot option VGA=791 was able to boot to desktop. In grub I have set the VGA=791 option aswell.

    However, when booting from HDD , the boot halts just before I expected to see the desktop. Instead i get a blinking cursor and nothing more. I saw this several times also with the LiveCD when i choose a different option than core and when I did not set the VGA option.

    Question is now if the iso that I choosed really IS the same as the LiveCD core option or if there are other settings / boot options I could use to force the correct graphical settings.

    Second is that if above iso aint the correct one, could I solve the problem by simply extracting the rootfs4/3/2/1 images from the livecd and to my partition in stead of using the mentioned iso?

  • Profile picture of kultex kultex said 2 months, 3 weeks ago:

    compare the the whole /etc/X11/xorg.conf.d section from liveCD and installed version.

    In live CD this section is normally empty – but when you boot the installed version the first time wrong, it stays like this and the grub entry VGA=791 does ont overwrite the wrong config – is just my theory not proved….

  • Profile picture of Zainka Zainka said 2 months, 2 weeks ago:

    Thanks. I was able to fix the issue, or more corrctly, remove it without figuring out WHY it was not woriking at first. I simply copied the content of the X11 folder form a booted livecd into the installed one. Everything worked perfectly from then on.

    thanks